BGP OSPF 設定例(1)

ネットワーク構成

excelVisioではなくEVENGを使用しています。

正常経路

ISR5→ISR1→ISR3→ISRv

 

リンク障害 項番1 ISR1 Gi1-ISR3 Gi1 閉塞

R5→R1→R2→R4→R3→R6

 

リンク障害 項番2 ISR5 Gi1-ISR1 Gi3 閉塞

R5→R2→R1→R3→R6

 

筐体障害 ISR 1 

R5→R2→R1→R3→R6

 

-------投入コンフィグ-------

■ISR1■

conf t
hostname ISR1
!
interface GigabitEthernet1
 ip address 10.1.13.1 255.255.255.0
 no sh
!
interface GigabitEthernet2
 ip address 10.1.12.1 255.255.255.0
 no sh
!
interface GigabitEthernet3
 ip address 172.16.15.1 255.255.255.0
 no sh
!
router ospf 1
 redistribute bgp 65001 metric 100 metric-type 1 subnets
 network 172.16.15.0 0.0.0.255 area 0
!
router bgp 65001
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.1.12.2 remote-as 65001
 neighbor 10.1.12.2 password 0123456789
 neighbor 10.1.13.3 remote-as 65002
 neighbor 10.1.13.3 password 0123456789
 !
 address-family ipv4
  bgp redistribute-internal
  network 192.168.5.0
  neighbor 10.1.12.2 activate
  neighbor 10.1.12.2 next-hop-self
  neighbor 10.1.12.2 soft-reconfiguration inbound
  neighbor 10.1.13.3 activate
  neighbor 10.1.13.3 soft-reconfiguration inbound
  neighbor 10.1.13.3 route-map LP in
  neighbor 10.1.13.3 route-map MED out
  neighbor 10.1.13.3 filter-list 1 out
 exit-address-family
!
!
!
!
ip as-path access-list 1 permit ^$
ip as-path access-list 2 permit ^65002_
!
access-list 1 permit 192.168.5.0 0.0.0.255
!
!
route-map LP permit 10
 match as-path 2
 set local-preference 200
!
route-map MED permit 10
 match ip address 1
 set metric 110

 

■ISR2■

conf t
!
hostname ISR2
!
interface GigabitEthernet1
 ip address 10.1.24.2 255.255.255.0
 no sh
!
interface GigabitEthernet2
 ip address 10.1.12.2 255.255.255.0
 no sh
!
interface GigabitEthernet3
 ip address 172.16.25.2 255.255.255.0
 no sh
!
router ospf 1
 network 172.16.25.0 0.0.0.255 area 0
!
router bgp 65001
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.1.12.1 remote-as 65001
 neighbor 10.1.12.1 password 0123456789
 neighbor 10.1.24.4 remote-as 65002
 neighbor 10.1.24.4 password 0123456789
 !
 address-family ipv4
  network 192.168.5.0
  neighbor 10.1.12.1 activate
  neighbor 10.1.12.1 next-hop-self
  neighbor 10.1.12.1 soft-reconfiguration inbound
  neighbor 10.1.24.4 activate
  neighbor 10.1.24.4 soft-reconfiguration inbound
  neighbor 10.1.24.4 route-map LP in
  neighbor 10.1.24.4 route-map MED out
  neighbor 10.1.24.4 filter-list 1 out
  distance bgp 20 100 200
 exit-address-family
!
!
!
ip as-path access-list 1 permit ^$
ip as-path access-list 2 permit ^65002_
!
access-list 1 permit 192.168.5.0 0.0.0.255
!
!
route-map LP permit 10
 match as-path 2
 set local-preference 150
!
route-map MED permit 10
 match ip address 1
 set metric 120

■ISR3■

conf t
!
hostname ISR3
!
interface GigabitEthernet1
 ip address 10.1.13.3 255.255.255.0
 no sh
!
interface GigabitEthernet2
 ip address 10.1.34.3 255.255.255.0
 no sh
!
interface GigabitEthernet3
 ip address 172.16.36.3 255.255.255.0
 no sh
!
router ospf 1
 redistribute bgp 65002 metric 100 metric-type 1 subnets
 network 172.16.36.0 0.0.0.255 area 0
!
router bgp 65002
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.1.13.1 remote-as 65001
 neighbor 10.1.13.1 password 0123456789
 neighbor 10.1.34.4 remote-as 65002
 neighbor 10.1.34.4 password 0123456789
 !
 address-family ipv4
  bgp redistribute-internal
  network 192.168.6.0
  neighbor 10.1.13.1 activate
  neighbor 10.1.13.1 soft-reconfiguration inbound
  neighbor 10.1.13.1 route-map LP in
  neighbor 10.1.13.1 route-map MED out
  neighbor 10.1.13.1 filter-list 1 out
  neighbor 10.1.34.4 activate
  neighbor 10.1.34.4 next-hop-self
  neighbor 10.1.34.4 soft-reconfiguration inbound
 exit-address-family
!
!
!
ip as-path access-list 1 permit ^$
ip as-path access-list 2 permit ^65001_
!
access-list 1 permit 192.168.6.0 0.0.0.255
!
!
route-map LP permit 10
 match as-path 2
 set local-preference 200
!
route-map MED permit 10
 match ip address 1
 set metric 110

■ISR4■

conf t
!
hostname ISR4
!interface GigabitEthernet1
 ip address 10.1.24.4 255.255.255.0
 no sh
!
interface GigabitEthernet2
 ip address 10.1.34.4 255.255.255.0
 no sh
!
interface GigabitEthernet3
 ip address 172.16.46.4 255.255.255.0
 no sh
!
router ospf 1
 network 172.16.46.0 0.0.0.255 area 0
!
router bgp 65002
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.1.24.2 remote-as 65001
 neighbor 10.1.24.2 password 0123456789
 neighbor 10.1.34.3 remote-as 65002
 neighbor 10.1.34.3 password 0123456789
 !
 address-family ipv4
  network 192.168.6.0
  neighbor 10.1.24.2 activate
  neighbor 10.1.24.2 soft-reconfiguration inbound
  neighbor 10.1.24.2 route-map LP in
  neighbor 10.1.24.2 route-map MED out
  neighbor 10.1.24.2 filter-list 1 out
  neighbor 10.1.34.3 activate
  neighbor 10.1.34.3 next-hop-self
  neighbor 10.1.34.3 soft-reconfiguration inbound
  distance bgp 20 100 200
 exit-address-family
!
!
virtual-service csr_mgmt
!
ip as-path access-list 1 permit ^$
ip as-path access-list 2 permit ^65001_
!
access-list 1 permit 192.168.6.0 0.0.0.255
!
!
route-map LP permit 10
 match as-path 2
 set local-preference 150
!
route-map MED permit 10
 match ip address 1
 set metric 120

 

■ISR5■

conf t
hostname ISR5
!
interface Loopback1
 ip address 192.168.5.5 255.255.255.0
 ip ospf network point-to-point
!
interface GigabitEthernet1
 ip address 172.16.15.5 255.255.255.0
 no sh
!
interface GigabitEthernet2
 ip address 172.16.25.5 255.255.255.0
 no sh
!
!
router ospf 1
 network 172.16.15.0 0.0.0.255 area 0
 network 172.16.25.0 0.0.0.255 area 0
 network 192.168.5.0 0.0.0.255 area 0
!
ip route 192.168.6.0 255.255.255.0 172.16.25.2 200

 

■ISR-6■

conf t

hostname ISR6

!

interface Loopback1
 ip address 192.168.6.6 255.255.255.0
 ip ospf network point-to-point
!
interface GigabitEthernet1
 ip address 172.16.36.6 255.255.255.0
no sh
!
interface GigabitEthernet2
 ip address 172.16.46.6 255.255.255.0
 no sh
!
router ospf 1
 network 172.16.36.0 0.0.0.255 area 0
 network 172.16.46.0 0.0.0.255 area 0
 network 192.168.6.0 0.0.0.255 area 0