VRF(static)

VRFはルーティングテーブルをわけるための技術です。

FGTではVRFのことを、VDOMと呼び

BIG-IP ではVRFのことをRoute domainと呼んでいます。

 

VRF-liteはエンタープライズネットワークやデータセンターネットワークで使用され、

VRFはキャリアのバックボーンなどで使用されています。

 


確認コマンド
ter len 0
show run
show ip route vrf *

 

■■SW1 投入コンフィグ■■
Shostname SW1
!
ip vrf AAA
 rd 1:1
!
ip vrf BBB
 rd 2:2
!
ip vrf CCC
 rd 3:3
!
ip vrf DDD
 rd 4:4
!
ip vrf EE
 rd 5:5
!
ip vrf EEE
!
!
!
interface GigabitEthernet1/0/3
 switchport trunk allowed vlan 10,20,30,40,50
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 switchport trunk allowed vlan 10,20,30,40,50
 switchport mode trunk
!
interface Vlan10
 ip vrf forwarding AAA
 ip address 10.10.10.1 255.255.255.0
 no sh
!
interface Vlan20
 ip vrf forwarding BBB
 ip address 10.20.20.1 255.255.255.0
 no sh
!
interface Vlan30
 ip vrf forwarding CCC
 ip address 10.30.30.1 255.255.255.0
 no sh
!
interface Vlan40
 ip vrf forwarding DDD
 ip address 10.40.40.1 255.255.255.0
 no sh
!
interface Vlan50
 ip vrf forwarding EEE
 ip address 10.50.50.1 255.255.255.0
 no sh
!
ip route vrf AAA 0.0.0.0 0.0.0.0 10.10.10.2
ip route vrf AAA 0.0.0.0 0.0.0.0 10.10.10.3
ip route vrf BBB 0.0.0.0 0.0.0.0 10.20.20.2
ip route vrf BBB 0.0.0.0 0.0.0.0 10.20.20.3
ip route vrf CCC 0.0.0.0 0.0.0.0 10.30.30.2
ip route vrf CCC 0.0.0.0 0.0.0.0 10.30.30.3
ip route vrf DDD 0.0.0.0 0.0.0.0 10.40.40.2
ip route vrf DDD 0.0.0.0 0.0.0.0 10.40.40.3
ip route vrf EEE 0.0.0.0 0.0.0.0 10.50.50.2
ip route vrf EEE 0.0.0.0 0.0.0.0 10.50.50.3
!
end

SW1#show ip route vrf *
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


Routing Table: Mgmt-vrf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


Routing Table: AAA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.10.10.3 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.10.10.3
                [1/0] via 10.10.10.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.10.10.0/24 is directly connected, Vlan10
L        10.10.10.1/32 is directly connected, Vlan10

Routing Table: BBB
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.20.20.3 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.20.20.3
                [1/0] via 10.20.20.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.20.20.0/24 is directly connected, Vlan20
L        10.20.20.1/32 is directly connected, Vlan20

Routing Table: CCC
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.30.30.3 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.30.30.3
                [1/0] via 10.30.30.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.30.30.0/24 is directly connected, Vlan30
L        10.30.30.1/32 is directly connected, Vlan30

Routing Table: DDD
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.40.40.3 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.40.40.3
                [1/0] via 10.40.40.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.40.40.0/24 is directly connected, Vlan40
L        10.40.40.1/32 is directly connected, Vlan40

Routing Table: EE
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


Routing Table: EEE
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.50.50.3 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.50.50.3
                [1/0] via 10.50.50.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.50.50.0/24 is directly connected, Vlan50
L        10.50.50.1/32 is directly connected, Vlan50
SW1#

確認コマンド
ter len 0
show run
show ip route

■■SW2 投入コンフィグ■■
ter len 0
show run
show ip route

conf t
!
hostname SW2
!
vlan 10,20,30,40,50
!
interface vlan 10
 ip address 10.10.10.2 255.255.255.0
  no sh
 !
interface vlan 20
 ip address 10.20.20.2 255.255.255.0
  no sh
!
interface vlan 30
 ip address 10.30.30.2 255.255.255.0
  no sh
!
interface vlan 40
 ip address 10.40.40.2 255.255.255.0
  no sh
!
interface vlan 50
 ip address 10.50.50.2 255.255.255.0
  no sh
!
interface GigabitEthernet 1/0/3
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,50
!
ip route   0.0.0.0 0.0.0.0 10.10.10.1
ip route   0.0.0.0 0.0.0.0 10.20.20.1
ip route   0.0.0.0 0.0.0.0 10.30.30.1
ip route   0.0.0.0 0.0.0.0 10.40.40.1
ip route   0.0.0.0 0.0.0.0 10.50.50.1
!
end

SW2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.50.50.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.50.50.1
                [1/0] via 10.40.40.1
                [1/0] via 10.30.30.1
                [1/0] via 10.20.20.1
                [1/0] via 10.10.10.1
      10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C        10.10.10.0/24 is directly connected, Vlan10
L        10.10.10.2/32 is directly connected, Vlan10
C        10.20.20.0/24 is directly connected, Vlan20
L        10.20.20.2/32 is directly connected, Vlan20
C        10.30.30.0/24 is directly connected, Vlan30
L        10.30.30.2/32 is directly connected, Vlan30
C        10.40.40.0/24 is directly connected, Vlan40
L        10.40.40.2/32 is directly connected, Vlan40
C        10.50.50.0/24 is directly connected, Vlan50
L        10.50.50.2/32 is directly connected, Vlan50
SW2#


確認コマンド
ter len 0
show run
show ip route

■■SW3 投入コンフィグ■■
SW3
!
hostname SW3
!
interface GigabitEthernet1/0/4
 switchport trunk allowed vlan 10,20,30,40,50
 switchport mode trunk
!
interface Vlan10
 ip address 10.10.10.3 255.255.255.0
 no sh
!
interface Vlan20
 ip address 10.20.20.3 255.255.255.0
 no sh
!
interface Vlan30
 ip address 10.30.30.3 255.255.255.0
 no sh
!
interface Vlan40
 ip address 10.40.40.3 255.255.255.0
 no sh
!
interface Vlan50
 ip address 10.50.50.3 255.255.255.0
 no sh
!
!
ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 0.0.0.0 0.0.0.0 10.20.20.1
ip route 0.0.0.0 0.0.0.0 10.30.30.1
ip route 0.0.0.0 0.0.0.0 10.40.40.1
ip route 0.0.0.0 0.0.0.0 10.50.50.1
!
end

SW3#show ip route
Extended Host Mode is enabled
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 10.50.50.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.50.50.1
                [1/0] via 10.40.40.1
                [1/0] via 10.30.30.1
                [1/0] via 10.20.20.1
                [1/0] via 10.10.10.1
      10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C        10.10.10.0/24 is directly connected, Vlan10
L        10.10.10.3/32 is directly connected, Vlan10
C        10.20.20.0/24 is directly connected, Vlan20
L        10.20.20.3/32 is directly connected, Vlan20
C        10.30.30.0/24 is directly connected, Vlan30
L        10.30.30.3/32 is directly connected, Vlan30
C        10.40.40.0/24 is directly connected, Vlan40
L        10.40.40.3/32 is directly connected, Vlan40
C        10.50.50.0/24 is directly connected, Vlan50
L        10.50.50.3/32 is directly connected, Vlan50
SW3#